Is WP Rocket Compatible with Gutenberg and WordPress 5.0?

Yes, WP Rocket is compatible with Gutenberg, the new content editor in WordPress 5.0+

To manage the Cache Options, click on the Document settings in the sidebar on the right: 

Disable Embeds

If you have activated the Disable Embeds feature be aware that in the post editor you will see this message when you try to embed whitelisted content, such as a YouTube video: 

However, the embedded content will display correctly on the front end of your website:

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.