Using iThemes Security with WP Rocket

WP Rocket is compatible with the iThemes Security plugin.

iThemes Security has an option to prevent system files to be editable (which is a reasonable security feature). However, WP Rocket needs permission to write in .htaccess, wp-config.php as well as to create advanced-cache.php and the cache and wp-rocket-config folders. Folder permissions should be set to 755, 775 or even 777 on some hosting platforms. Files permissions should be set to 644 (default WordPress values).

Once you install WP Rocket, make sure you have turned off System Files Protection:

In case that option is turned on when you activate WP Rocket, cache will not be enabled and you will see the following error: